Yet another feedback request :)

Hi everyone!

I’d appreciate any feedback on my project, which generates a random 5-a-side football team! In particular:

  • How could I improve my code to make it more readable or efficient?
  • How could I improve my README to make it clearer?

Link to repository is here :slight_smile:
ksham1/Random-Message-Generator (github.com)

Thanks!

Your chooseRandomPlayer function is returning an index to an array. This is a bit misleading (because of the name). I’d expect an actual player to be returned (which might mean some re-arrangement). You could keep it as is, but the naming would have to change, and then there is the danger that the function gets used in an unexpected way (meaning you have to keep track of the correctness of the indices as you go along which is not generally desired).

1 Like

Thanks! Super helpful :slight_smile: