@willieldanem well done, here's what I think you can improve, if I was grading your code, these are the comments you'd get back from me:
getLowAndHigh would be more useful if you split it in two and returned the results instead of printing them. Right now it's doing three jobs: Finding min, finding max, printing. It should be doing just one of those things.
The above suggestion is really the only one, but if not for that, then the funciton should be renamed to
void printLowAndHigh (no return type, and it prints, it doesn't give/get anything) so that its behaviour matches its signature.
In "real-world" code:
min = Collections.min(grades);
max = Collections.max(grades);
So if you were to implement the functionality of finding min/max, that would of course be avoiding the exercise, but for any other purpose, that might be what you'd rather use.