Why is "git init" not working?


#1

I type git init, but I can't pass the lesson. I am told that Initialized empty Git repository in /home/ccuser/workspace/daw/.git/. I am confused as to what I am doing wrong.
Note: I got a No such file or directory message after typing cd personal-website and cd personal-website/


#2

You either didn't create it or you're looking in the wrong place. Look around in your home directory.

What prevents you from passing the checkpoint? Which checkpoint are you referring to? (link to exercise and the number of the checkpoint)

That is a success message, so I'm very confused about what isn't working.


#3

You should run git init in the directory of your website, which means you'll need to navigate there first.

If you're unable to find it, did you create that directory earlier and confirm that the files were created?

Are you looking in the right place? Does it show up if you do
ls -RF ~
?


#4

To pass this I needed to cd /home/ccuser/workspace/daw then create personal-website using the jekyll new command. After creating the static website, cd to personal-website and run git init. That was a bit painful to figure out. :slight_smile:


#5

Were you able to display the website when you created it the first time?

And if so, is it definitely not still there? If you run
find ~ -type d -name css
do you only get one hit?


#6

Thank you so much! I had the same problem and fixed it with your help!!! :slight_smile:


#7

Thank you, william_parker!


#8

william_parker do you have a screen shot for me? I have the same problem but I can't get it right to pass instruction number 2


#9

A post was split to a new topic: Am entering the command git init and nothing is happening


#10

i found closing the session an opening it again worked


#11

The problem is that the virtual console does not upload from the previous lesson where you actually created the jekyll. Do all that again in the new lesson and you'll be good to go.


#12

The same thing is happening to me. It tells me "Reinitialized existing Git repository in /home/ccuser/workspace/daw/.git/" and doesn't let me move on.


#13

Is that the directory that should be a repository though?


#14

thank you so much for this oh my gosh I was so frustrated!


#15

Thank You, worked perfectly.


#16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.