Why does nothing happen when I press Run?

I am seeing this problem as well.

I get the same time out error as @stevencopeland.

Hi @jackilynnmillard1971, welcome to the forums!

What lesson is this on?

This is in lesson 15. String Formatting with %, Part 2

All of that works for me… what browser are you in?

Hi all,
I got the same error message on Google Chrome, but Microsoft Edge is workable.

Still the very same problem. Is there a bug? I do exactly as it says and replae the ___ with %s and then the last one with %. I get to answer the first question, but then I thinks for some time and then gives me this error messages:

Traceback (most recent call last):
File “python”, line 1, in
ExecTimeoutException: Program took too long to terminate.

How do I do to continue? I use chrome as recomended.

Hello all! After a little bit of testing I discovered that problem. I will submit a bug report on the super user bug reporting platform, and would recommend ya’ll do the same on the normal bug report. Right now, if you have the correct code, I would recommend just clicking the “Get Solution” button.

Woud this still allow me to continue as normal?

Yes…

But hold on one second

Can you send a screenshot of the exercise? I just found something that might fix it.

This time, when you run the code, click on the black screen where the code result is supposed to come from and start typing.

This is the result I get:


That’s what I’m doing, but the second question never pops up.

Can you send just your raw code? My code still runs completely fine.

Some of these old courses have exhibited signs of instability when attempting to get user input. The workaround for this is to declare the variables literally and bypass the raw_inputs, altogether.

name = "Your name"
quest = "Your quest"
color = "Your favorite color"

Comment out the first three lines in the sample above.

2 Likes

Don’t know if you still need an answer, but I had the same problem on Firefox, changed to Chrome and it worked…

With Firefox, it works when you use the reply like
What is your name? “Mike”
but not
What is your name? Mike
The second option works with Chrome though

1 Like

I could see the first question on the console but it ran in error, then I just clicked on the ‘console’ area and typed. It was resolved.
My ans attached

so this is my code:
name = raw_input("What is your name? ")
quest = raw_input("What is your quest? ")
color = raw_input("What is your favorite color? ")

print "Ah, so your name is %s, your quest is %s, "
“and your favorite color is %s.” % (name, quest, color)

but this is what happens in the console:
What is your name? bob
Traceback (most recent call last):
File “python”, line 1, in
ExecTimeoutException: Program took too long to terminate.

Why does this happen? Is something wrong with my server or with my code?

1 Like

i just random hit the right panel and type randomly and it came out.
also cant do anything at first but it just suddenly worked. maybe its bug

@mtf
Can this be pinned at the top? (I had to scroll way down to find the solution and this wasn’t even the first post I found that explained how to get around the error.)

1 Like

Unfortunately it cannot be pinned. We could clean up the thread a little. Maybe that will help.