Whenever I try to run it this happens. HELP!


#1

Strings and Console Output


#3

I’m having the same problem. I tried removing the continuation marker, resetting the program, and nothing seems to work.


#4

Seems fine on my end, not that this helps you at all, try starting the browser in private mode and disable any add-ons you have running.


#5

It works for me.
This is what I have:

name = raw_input("What is your name? ")
quest = raw_input("What is your quest? ")
color = raw_input("What is your favorite color? ")

print "Ah, so your name is %s, your quest is %s, " \
"and your favorite color is %s." % (name, quest, color)

#6

It seems like the picture given doesn’t tell us if you got the question correct or incorrect.
If it takes to long to respond, I recommend you refresh your page or change your browser.
For some reason, on the console on the right of the picture given, it looks like there is a subroutine, from the words “return”.
To me I think this is a troll. It looks like you put this into the console.


#7

Hi alycat27!

For this specific exercise you will enter your answer in the raw_input portion.

For example: name = “alycat27”

Then, you will delete the portion that states (“What is your name?”)

From here, you will do this for quest and color. Once you have done that, hit run. Your string looks correct!

All the best!


#8

Hey chipjumper 70810,

Check out my reply below!

Happy coding!


#9

I’m new to this but I don’t think that’s normal


#10

This still isn’t the solution though. The last line of the instructions tell us to input our answers into the console as they appear. If we’re replacing the values ahead of time then the exercise isn’t doing what it’s supposed to since that’s the whole point of having the ‘raw_input’ code there in the first place.


#11

@eldonmcguinness had the correct though process.

I had uBlock Origin running in Chrome while doing this exercise the first time. After I disabled it, I reloaded the page and the exercise ran as intended. Try disabling any adblocker you have running in your browser while on this domain.


#12

Hi teethslapper!

Thanks for the info! Sorry if I confused anyone.

All the best!


#13

I paused adblock and it worked c:


#14

I was getting the same error as alycat27


On bare-bones Firefox, no add-ons, Win10. Tried the problem on my Ubuntu netbook, worked fine there.


#15

Hey sys, I believe that’s because Firefox comes with a built in adblocker. I could be wrong but that’s my guess.


#16

I think I also have the same problem with yours.

Before I enter this forum, I have tried everything that I could think of… My final trying is like the picture below↓

In case of the picture could not be seen, I copy my code here:

name = raw_input("Kelly ")
quest = raw_input("get high pay ")
color = raw_input(“green”)

print “Ah, so your name is %s, your quest is %s,
and your favorite color is %s.” % (name, quest, color)

And then the result is like this:

Kelly get high pay greenAh, so your name is SCT, your quest is if type(error) == ValueError:,and your favorite color is return "Make sure to use a lowercase “s” with %s. Python told us about the following error: " + str(error).

Could anyone tell me where I put it wrong?

Thank you very much!


#17

I had the same problem and i keep getting the same even though the code was right. So i refreshed the page and tried it again. And it worked.


#18

After mulit time of trying to solve it. it look like that on line 1-3 the ? and the " need a space between them.I hope this help


#19

The difference between yours and theirs is that you have spaces before the ending quotation marks on the top three lines


#20

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.