When I try to download jekyll it says permission Thdenied


#1

This is specifically what it said:

ERROR: While executing gem ... (Gem::FilePermissionError)
You don't have write permissions for the /Library/Ruby/Gems/2.0.0 directory.

What happened?


#2

We'll look around for someone who hasn't done the module yet and see if they can work through it without issue. If they repeat the issue, then we have a problem that is reproducable and we can report it.


#3

I tried this course from beginning just now and on exercise 3 (that's where you are stuck I suppose?), I passed as expected by the exercise:

@OP: Did you try reloading the page and trying multiple times? Tried clearing cache? Cookies?


#4

That's on a mac, and that directory is probably owned by root.

Add --user-install

$ gem install --help | grep -A1 user-install
        --[no-]user-install          Install in user's home directory instead
                                     of GEM_HOME.

#5

Thanks, That worked.


#6

I am having the same problem. what portion of that do I type on terminal


#7

First you type:

gem install jekyll --user-install

then:

$ gem install --help | grep -A1 user-install
--[no-]user-install


#8

The second command doesn't do anything besides printing two lines!

gem install --help will print lots of text. I take that text and feed it to grep, telling grep to look for text matching the option.

In other words, I searched through the help text.

A lot of programs have a --help option where you can look up what various options do which is particularly useful to check before running commands that are just copied from somebody else.


#9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.