What is going on?


#1

Everytime I hit “Run”, It’s starting to take 2-3 minutes to return an answer. And even if it’s correct (I literally copied and pasted code from the forums) it still gives me a red X. I have to wait about half an hour to “get Code” so I can move on. I am being tested on Ruby in 10 days!

Does this happen to anyone else? It only seems to be happening in this section. I have tried different wifi servers and it’s the same thing. I’ve tried restarting everything and it does nothing. Please help!! This is an actual nightmare.


#2

which exercises does it involve? Can you you share the urls?

Can you show screenshots of the problem?


#3

The only way past it is to wait for “get Code” and that doesn’t always work. When it does, there is no difference whatsoever between what I type and what’s correct but that’s the only way I can get a green tick and move past it.

I saw a post on here from August with someone who had the exact same thing. It’s not just me, other posts of people saying something similar when it comes to the question 4,5 and 6.


#4

I don’t know if the code in this is actually wrong or not. If so, there are no notes explaining why. And I have to wait 2-3 minutes for each time I hit “Run”.


#5

I’ve noticed that this tends to happen on anything where you can input data on the black screen to the left (can’t remember what it’s called).


#6

but you learned that gets.chomp is a function which prompts the user running the program (in this case, you) for input, so if you then click on the output window (black screen on the right), then you can type a word, press enter, and submit this input into the program


#7

It’s doesn’t always let me put anything into the output window.

So with this for instance, this isn’t even a question. I’m supposed to merely click Run so I can carry on, why does it come back to me with a red X.


#8

And it’s not letting me enter anything on the output window.


#9

Can you share the exercise url? I can’t find the exercise you are at

that is a bug, let me check


#10

https://www.codecademy.com/courses/learn-ruby/lessons/thith-meanth-war/exercises/congratulationth?action=lesson_resume


#11

Hi @Charsv5, I’m unable to reproduce this bug – being unable to reproduce an issue makes it really really hard for engineers to find out what is going wrong. Does this happen for you on different browsers (e.g. Chrome and Firefox), in incognito mode, and in different locations (e.g. work vs. home – where there are often different firewall settings)?


#12

I have tried a different browser and incognito mode and it hasn’t made a difference. I had tried at home and now I’m at the library and I still can’t move past it but it was n’t as bad at home. Could it be because the library is public wifi?

I can’t move past the last bit in Thith menth war because it’s not a question and I can’t get the “get code” prompt up on my screen to move past it. I’m officially stuck!


#13

for this specific exercise, what happens when you enter a single word in the prompt, like i did:


#14

No it’s not about the precise excersize, it’s happening to all questions. It’s a bug, it says I got it wrong even when I get it right. I can’t even input any data on to the output screen.


#15

I get that, but given we can’t replicate the bug, i was looking at the differences between our code. We can’t report a bug we can’t reproduce.


#16

Hey @Charsv5, if you get in touch with our support team here they may be able to help you out with being stuck. Like us, they won’t be able to report a bug that they can’t reproduce, but they may be able to assist with your immediate problem of being unable to progress through the content.


#17

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.