VScode

image


I tried to install Visual Studio just to see if I could practice some coding off site. However I am getting the error posted in my image. I tried following the guide in the C++ build your own text adventure tutorial video, but it doesn’t reference any error like this.

Be careful when referncing “visual studio” and (“visual studio code”/“vscode”) as they aren’t the same thing (e.g. when searching the web for guidance).

You’re on Windows aye? The GNU C compiler (the one it seems to be trying to use) wouldn’t normally be included on Windows. Whilst you can install it directly, run via WSL or a virtual machine if you’re just starting out that might be adding unnecessary complexity for now.

I’d highly suggest following the VS Code docs for getting started (especially if you want the easy run and debug tools to work too).

You have options for getting various compilers up an running (you only really need one though), link to the vs code tutorials on C++ (choose a Windows specific guide :slightly_smiling_face:)-

2 Likes

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.