Update a Destination 7 step 6 - "Edit" Link


#1

Even though i have added the link_to and have it working in the browser, i can not get to
the next step, tried re-loading page, re-doing exercise from scratch, same result
Code is below:

<!-- Your code here -->
        <%= image_tag @destination.image %>
        <h2><%= @destination.name %></h2>
        <p><%= @destination.description %></p>
   			<%= link_to "Edit" , edit_destination_path(@destination) %>
      </div>

full link is: https://www.codecademy.com/en/courses/learn-rails/lessons/one-many/exercises/one-many-update-destination-i
The error is: Did you add the edit link?
The browser working all correctly, still system giving me error.


Associations 1 lesson #7 step 6
#2

Hi @tzurcan,

My code for the link is the same, and it worked :confused:

  1. Does anything change if you remove the <h2> and <p> tags around the title and description?
  2. Could you try switching browsers, and see if that passes you?

#3

Hi @zystvan,

It doesn't work for me either. I get the same error message "Did you add the link to the destination?"

Unit 3: ASSOCIATIONS > 6. Show a destination (6/9)

Any update on this! Kinda struck here for the last 2 days. Any help would be greatly appreciated. Thanks!


#4

I have the same problem


#5

Also had same issue. Refreshed/reloaded a few times and it was accepted.


#6

Hi, tried that, no difference, still stuck on this step


#7

@viggy-r Please create a new topic, you have a different issue.


@wanyi000001 @jeanmw Do you have the same code as @tzurcan? If not, please create a new topic also.


@tzurcan That screenshot is showing different code than what you copy/pasted in your post earlier. For the code in your screenshot, try adding an equal sign (=) to the front of the <% link_to ... %>, since an equal sign there indicates something to be shown on the page (look at the way you're displaying the image, name, or description).


#8

Try remove the space between "Edit" and ","


#9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.