Unknown error when displaying all messages


#1

I’m at a loss on step 4. This is the second time I’ve followed the instructions to the letter and have been presented with a test error:
Oops! The test returned an error. Maybe you have a syntax error, or a typo. Hide error.
/home/ccuser/.gem/ruby/2.3.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now

I have tried both manually typing out the HTML code in the lesson as well as copy/pasting but the error keeps me from moving to the next step.
NOTE: This is not the first time I’ve had this exact problem on a previous Rails lesson and just ended up giving up.

I’m posting this here because the “report a bug” button does nothing when clicked -_-


#2

A post was split to a new topic: Red X on Step 1


#3

Hi @jhuddleston333,

Please report the error through the form beneath the instructions on the left, then try one of these solutions:

https://discuss.codecademy.com/t/tzinfo-data-error/85895?u=zystvan
https://discuss.codecademy.com/t/pages-controller-rb-not-in-folder/84291/12?u=zystvan
https://discuss.codecademy.com/t/browser-not-working/83754/3?u=zystvan


#4

I’m posting this here because the “report a bug” button does nothing when clicked

Also none of the issues you linked are related to the issue I’m seeing.


#5

Sorry, I missed that sentence. The links I posted are all related to the error message you’re getting, though.

I’m not having any problems with the bug report form, is it possible you have an adblocker or firewall causing problems?


#6

Wow, yeah my ad blocker was preventing the “report a bug” button. I didn’t even think of that. Good catch!


#7

This topic has concluded.