Unable to type "$"


#1

Hi, I'm unable to get past Aliases II lesson 5 because I can't type "$" in the terminal window. I have tried the on-screen keyboard of Win8 and restarted the whole excercise 3 times using different web browsers, but it doesn't help. Can someone please help?


Exercise 6, Win 10, can't | and on screen keyboard doesnt work either
I am stuck on 55% - cat: │: No such file or directory
#2

Same for me with the pipe '|' symbol, stuck in the middle of the course and can't go further....tried keyboard, copy/paste, virtual Keybord from OS (win7) and virtual Keyboard from VirusProgramm, in different Browsers....


#3

Hi guys,

I've seen other people with the same issue (I haven't run into it) suggesting that you make sure you're using a QWERTY keyboard layout.
I use Dvorak on Ubuntu based Linux, and haven't had any issues with not being able to type certain characters in the Codecademy terminal, though.


#4

Well, I use Skandinavian keyboard which is basically the same except a few special characters (å, ä, ö). But otherwise there is no differences in the layout.


#5

Have you tried switching to QWERTY though/did QWERTY work for you?


#6

Here you can see the layout: https://upload.wikimedia.org/wikipedia/fi/a/ad/Skandinaavinen_näppäimistö.png

As I said it's basically the same as the normal keyboard, but I have to press ctrl+alt+4 instead of shift+4 to get "$". Maybe it has something to do with that.


#7

Just activate american layout so u can use it to type $. I had the exact same problem.


#8

Same for me, impossible to write pipe symbol. I´ve tried all options. The monitor no recognized the pipe from the virtual keyboard. I can not continue with "cat volcanoes.txt | wc" in 55%. Sorry.


#9

Found a workaround that works for me (win7). Annoying but works.
I'm using german keyboard schema. Pipe Symbol is at 'ctrl+alt+7' or 'altGr+7' (= three keys)

As mentioned, you have to switch the keyboard-schema, at least to type these single 'not working' characters, to a schema who has these chars as a 'two-key-combination'.

I searched at https://msdn.microsoft.com/en-us/goglobal/bb964651.aspx a keyboard schema who has the pipe symbol just with two keys. And I found 'Latvian QWERTY', who has the pipe at its 'shift+\' (= two keys). Added this schema to my German(swiss) and German(french), and placed the language switcher at the toolbar.

If I need the pipe, switch to Latvian, hitting shift+< on my keyboard, and than switch back to german.

As I said, annoying, but works, until this is fixed. I guess the editor (its JavaScript) has problems to 'catch' three-keys combinations.

Cheers
Roger


#10

One way would be to use the ascii code e.g. for $ it would be hold ALT+36 or for the pipe ALT+124


#11

Thanks for your hint.
But that doesn't work, at least for me.
Seems like the editors JavaScript can't 'read' this too.


#12

Same problem here with "|" character on "cat volcanoes.txt | wc"


#13

working with ALT+124, thanks haxor789


#14

None of these workarounds work for me. I have tried holding down ALT and pressig 36. The prompt $ changes to (arg: 36). But I get no dollar sign.


#15

Take that dollar sign from your post and copy and paste it?


#16

How can I paste it? Ctrl-V doesn't work. When I right click I get no paste option.


#17

In consoles you often need to use CTRL+SHIFT+V


#18

That didn't work either unfortunately. CTRL+SHIFT+V inputs ^V instead of $.


#19

Ok tested it myself and it fails for me as well :frowning:
What worked is to use ALT + 36 where you take 36 from the num block not from the numbers above your letter keys.


#20

I'll try that nd report back when I come home later today. I don't have a num lock button on my laptop. When I tried alt+36 on the number pad of the Mac keyboard it flipped my screens :smile: