Trying to import sklearn issues

I’m up to the part in the Python 3 course where I have to download a bunch of stuff to code outside of Codecademy. I went through ■■■■ trying to get Jupyter installed on my chromebook, gave up and tried the mac. But I’m up to the part where I have to install and then import sklearn and though it shows as installed it will not import and it says “command not found”.
Where am I going wrong? Everything is spelled just fine. The instructions for how to troubleshoot this tell me to repeat the installation step again which I did, but still nothing.
I can’t continue the course if I can’t figure this out so any suggestions of help would be greatly appreciated.
I find the Codecademy resources explaining how to install everything are just leading me to web page after web page and now I’m just confused and don’t know if I’ve missed a step.

It usually means that sklearn was installed on a different version of Python. How did you install it?
was it like this: “pip3 install package name”?

Or, a better way:
python3 -m pip install scikit-learn

Thank you! it finally worked. The instructions given don’t have the 3 there.

1 Like

Thank you! This fixed my issue as well.