Tried reporting a bug, forum won't let me post

I’m having an issue with the Treasure Hunter project in the “Create Video Games with Phaser.js” course, and tried to report it in the bug reporting forum, but the forum won’t let me post. Figured I’d try here…

EDIT: Success! I can at least post here if nowhere else. Doesn’t help me with my original problem though. The Community > Bug Reporting forum’s “new topic” button isn’t clickable. If I look under the javascript tags, it’ll let me at least click the button, but after typing out my post, it won’t actually let me share it.

(post deleted by author)

image
^ screenshot of the error message

hi there! The bug reporting category is requires you to be a Trust Level 1 user or higher, which means brand new accounts like yours would not be able to post in there.

Sorry for the confusion!

Okay, so how can I address the Treasure Hunter bug?

Feel free to share here and I’ll pass it along to the team :+1:

or you can reach out customer support https://help.codecademy.com

Okay, here’s the link to the project: https://www.codecademy.com/paths/create-video-games-with-phaser/tracks/game-dev-learn-javascript-arrays-and-loops/modules/game-dev-project-arrays-and-loops/projects/treasure-hunter

Basically it seems like none of the sprites are loading. According to the instructions, even on a freshly reset workspace, I should still see a game board after the start screen, but all I get is black. Tried loading the sprite for the gold coin, as per step 6’s instructions, and that won’t show up either. The start screen loads, but as soon as I “click to start”: nothing.

ok, so nothing is loading on the right-hand side pane like here?

The treasure hunter screen loads, but if you click on it, nothing else. I get a black screen after that, where I’m supposed to see the game board.

Oof, nevermind. I figured out what the problem was! It wasn’t progressing because I’d made a syntax error somewhere and it was crashing. I’m not used to not seeing my console, so I couldn’t tell what the problem was, just that it wasn’t working.