Thith Meanth War! Not working


#1



This page is not working. I click save and submit code and the the button stays blue with its wheel spinning. Yes, I typed in something in the results area. Yes, I've tried refreshing the page and doing this over and over and over. The page is broken, I can't even progress forward because what you're asking a user to do doesn't work. Please fix this bug.


https://www.codecademy.com/courses/ruby-beginner-en-JdNDe/0/1?curriculum_id=5059f8619189a5000201fbcb


No error message. If you type in something in the results box, the blue button and wheel just spins. Nothing happens, the page hangs, something isn't working.


Replace this line with your code.


#2

Alternative explanation: Your code tells ruby to wait for user input, so ruby waits until it gets it


#3

I am inputting something after the colon, "Thtring, pleathe!:", and the blue wheel in the button just spins. There is a bug. I should be able to type anything after the colon and have a success happen with the button but that doesn't occur, it just hangs and does nothing.


#4

Are you also inputting a newline character? (enter key)

Maybe you're asking for input several times.

"works on my end"

They did change out some stuff on the back-end having to do with the runners, so maybe, just maybe it's related to that


#5

new line character made it go through. What part of that code or instructions helps you understand that you need to put in a new line character? This intro has a flaw.


#6

It's generally used to submit things, though I see what you mean - they do say "run it and see what happens"


#7

That's right, so it needs to be updated to say add new line character before entering your string.


#8

I'm afraid I have no such capability, and cc would say that the course is being replaced and therefore be unwilling to make that change


#9

My code doesn't work. I've inputted a string after the colon
print "Thtring, pleathe!: " AND created a new line by pressing the return button. It doesn't work for me.


#10

i try to use the ".include?" function and it gives me an error, saying that ".include?" is an invalid function.
i tried not using the question mark, but it still didn't work. the funny thing is, the ".include" function turned blue when i typed it in. the question mark didn't turn blue, though.
i tried adding a exclamation mark and keeping the question mark, but that didn't work either.


#11

Getting User Input

Use print to ask the user for input.
Declare a variable called user_input and set it equal to the user's input using gets.chomp.

My code:

print "I was born in the month of _______."
user_input = gets.chomp

Where am I making a mistake?


#12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.