This site can’t be reached


#1

I figured out this problem! The DNS records for my domain name didn’t match the DNS records for my hosted zone. I copied the DNS records from my hosted zone into my domain name and then everything worked fine! I’m leaving the question just in case someone’s Google query leads them to this top solution part for the bottom question.

IGNORE THIS QUESTION. I FIGURED IT OUT.
I am having trouble trying to complete the CodeCademy Deploy a Website tutorial. I have attempted this tutorial 3 different times, each with the same problem. My Route53 page @www.bioinformaticsanalyst.com just has “This site can’t be reached” and the rest of that error message.

The Codecademy Tutorial that I am having trouble with is located at: https://www.codecademy.com/courses/deploy-a-website/lessons/aws-route-53/exercises/domain-names

The site I’m trying to host is just the default Jekyll blog output (“My Awesome Site” and a few pages). It serves fine (after I run the “jekyll serve” command out of the site’s directory) when I load on my computer. Also, my GitHub page (@davehalvorsen.github.io) loads just fine BEFORE I add a CNAME containing the text “bioinformaticsanalyst.com”. Adding that CNAME along with the AWS part of the tutorial, forwards a visitor for davehalvorsen.github.io -> bioinformaticsanalyst.com Here is an image from GitHub showing that my site is ready to be published at “bioinformaticsanalyst.com”.

Finishing the Route53 part of the tutorial always ends with the blank site with the “This site can’t be reached” error message. By "Route53 part of the tutorial, I specifically mean 1) adding the Type A-IPv4 address record of “http://bioinformaticsanalyst.com.” with the values of “192.30.252.153” and “192.30.252.154” and 2) adding the “www.bioinformaticsanalyst.com” CNAME record with the value of "davehalvorsen.github.io

Please send help! :slight_smile: What am I doing wrong?

Also, side-question: Why does Route 53 add periods onto all the domains? I think my domains should list as “bioinformaticsanalyst.com”, BUT all of them have a period on the end “bioinformaticsanalyst.com.”


#2

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.