There was a problem with the requested skill response


#1

I’m using the code copied from index.js and I get the correct invocation, it even gives me the correct response under the listen () function when I don’t response.
However when I respond I get
"There was a problem with the requested skill response"

I don’t know where to go to fix this.
It is also stopping me move on (as I can’t do the part where I get user input


#2

Hi @shanester007

I’m new here and had this problem. I know this thread is fairly old but I think it deserves an answer. I’ll try to answer it.

I spend about an hour looking over the lambda function when I got this error. Couldn’t find anything wrong so I tried to more forward but that became impractical since I couldn’t test my skill properly with this error popping up.

I thought the problem was in the lambda AnswerIntent function but it was not.

It’s in the Alexa skill’s AnswerIntent Sample Utterances. While testing, I would just but the answer as my response. The skill was expecting a reply of the format: Is it {answer} or I think it’s {answer}. You get the error that’s there is a problem with response.

So I added {answer} as a sample utterance, since I was uttering just the answer without ‘Is it’ or “I think it’s”, I suppose other’s are doing the same. The model isn’t recognizing the single word utterance as an AnswerIntent.

Hope this helps someone.