The git repository at 'c:\Users\(username)' has too many active changes, only a subset of Git features will be enabled

Hello Everyone,

I am having a problem with git in vscode. I think I set it up incorrectly. I have been getting a message that says ““The git repository at ‘c:\Users(username)’ has too many active changes, only a subset of Git features will be enabled.””

it seems that the file changes being traced range from cached items to app data to json files and everything in between. I am super confused. Any help would be greatly appreciated. Thanks

Here is a screen shot of the changes in vscode.

@method8467699982

I think you probably did git init inside the directory C:\Users\your_username. Doing this will cause Git to try and track every single file inside that directory and all its sub-directories. You shouldn’t be initializing a git repository in this folder, so you should probably go ahead and delete the .git folder.

To do so, you will need to enable viewing “hidden items” in your computer’s file explorer. First open the file explorer to C:\Users\your_username, click on the View tab, and select the “Hidden Items” checkbox:

Once that is selected, you should be able to see a folder called .git.
Delete that folder and git will no longer track any of those files.

Then create a new empty folder where you want to start your repository and do your git init in there.

3 Likes

@el_cocodrilo Thank you so much! I spent way too much time on this! lol