The 'git merge' command

<Below this line, describe in what way does your code behave incorrectly? Include ALL error messages.>

Hi,

I’ve been having some trouble with this exercise:

https://www.codecademy.com/pt/courses/learn-git/lessons/git-teamwork/exercises/git-merge-ii

the input and output of everything since exercise 1 of this unit is :

I think the image says it all.

Can anyone please help?

I had the same issue yesterday and filed a report about it… I don’t know what it has become, but the issue is real, the two repos are even.

I tested the following twice:

git fetch
git merge origin/master

# and

git fetch origin
gir merge origin/master

I’ve found the answer in another topic. I didn’t notice this earlier.

The quick solution is to close and open the bash (terminal) in the beginning of each exercicse.

1 Like

Well, that’s a good news ! But that would be a good thing if the problem was fixed…

That didn’t work for me. I still need a solution. Thanks :slight_smile:

Just Do

  1. Restart your terminal
  2. Git fetch origin
  3. Git merge origin/master
3 Likes

yeah i had the same issue. In order to get it to work after playing with it a bit i had to do
git fetch
git merge origin/master

I have the same issue
I have tried to restart terminal
git fetch
git origin/master

Still “allready up-to-date”
Did somebody tried other ways?

I tried so many things, but what seems to work for me was to edit and save one of the files (e.g. Physic.txt form my-quizzes): you can do that from lesson 6, save and then use;

git fetch
git origin/master.

Good luck!

I had the same problem but it worked just fine after i Restarted my terminal then do
Git fetch origin
Git merge origin/master

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.