Syntax error(?) while creating a react application


#1

The article on creating a react application instructs me that, to create a React application, I should run the following in the terminal:
create-react-app <name-of-app>
So, with my next project likely to be named Ravenous, I ran the following in my terminal:
create-react-app <ravenous>
and got the following error message:
bash: syntax error near unexpected tokennewline`

Now, as far as I understand, the newline character in Javascript is \n (or is it different in JSX?) Now, I see no hint of `\n’ anywhere in what I typed in my terminal. Has the syntax changed since the article was written?


#2

the use of < and > in bash redirects stdin and stdout, they shouldn’t be part of your command

<> are sometimes also used in documentation to display a value which needs replacing (like the name of an app)


#3

I’m sorry if there’s been some misunderstanding. I may not be looking carefully, but I see no < and > anywhere in create-react-app <ravenous>. There must be some other reason.


#4

Never mind, I ran the command without the <> and it’s working.


#5

i see < adn > around ravenous? The > will attempt to regulate the flow of stdout, but its not pointing anywhere, which is why you get an error

It was in my answer? Always a good idea to take the time not only to read, but also understand an answer you are given


#6

Sorry, I misunderstood your answer at first. Perhaps because I didn’t expect the answer to be so simple.