Stuck on 'Setting Initial State'


#1

https://www.codecademy.com/courses/react-101/lessons/this-state/exercises/initial-state?action=lesson_resume

There is no error code, but the instructions signal with a red cross instead of a green tick that the lesson has not been completed successfully. Have refreshed the screen, tried another browser = same result!



import React from 'react';
import ReactDOM from 'react-dom';

class App extends React.Component {
	// constructor method begins here:
	constructor(props) {
    super(props);
    this.state = { title: 'Best App' };
  }
	
  render() {
    return (
      <h1>
        Wow this entire app is just an h1.
      </h1>
    );
  }
}



#2

I’m having this issue with every step now. Even when I get code, nothing changes. I just have to submit 3 times and select ‘Get Code’ to move on.


#3

I’m having a similar issue as textpro20206.
Anything I submit just says it’s incorrect, but does not give feedback as to why.
I keep submitting it until it finally gives me the option to get the code.
I’ve copied and pasted before and after getting the code and they appear to be the same.


#4

I am experiencing this as well. I have been able to verify that the code from the show me the correct code is properly populating by resetting one of the lessons and submitting until I get the prompt. I hope they fix this soon or that this section is the only one that is broken like this.


#5

I had same issues since yesterday. I’ve checked my code which is exactly correct. So annoying.


#6

Same thing here! Pleae fix it… Thanks


#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.