Stuck in the Command Line: echo "Hello"


#1

I've been stuck at the that point where I should type echo "Hello" (after the prompt):

I type, as it says, after the prompt: $echo Hello (without the quotes "", because the codecademy's terminal isn't showing, or is not accepting my keybord's commands to the quotation marks " " as I type. I mean, I've been trying to type them, however, they don't appear on the Codecademy terminal).

That bug is happening only in the Commad Line course. I haven't had such a problem with the other courses I've been attending here on Codecademy.

I've tried to type: echo "Hello" (after the prompt), but it shows: echo Hello (which seems to be ok, due to the fact the word Hello apears on the following line of the terminal as if it had been echoed. The problem is the error message that blocks me from moving forward to the next exercise.


#2

@g4lvy,
Which Browser and Operating system are you using.....???


#3

I'm using Firefox (version: 44.0) and my OS is Mac OS X (10.7.5) Lion.

I've also tried using Chrome, but it happens the same!

PS.: I've tried typing both quotes: "" and ' ' . But, none of them appeared on the console only in the Commad Line Course.


#4

@g4lvy,
-1
Have you tried to Cut & Paste the statement....??
-2
At the $-prompt type
locale
echo $LANG
stty
and give us the results displayed...


#5

@leonhard.wettengmx.n

Yes, I've tried to Copy/ Cut & Paste the statement. The exercise or the page or the page's terminal doesn't allow me to Paste what I've Copied/ Cut, the option "Paste" is not available in the Edit menu bar.

I typed the command echo "Hello" on the bug's repport text box to check if it would have the same bug, but, it was ok and accepted the quotations, though.

I also did what you said and typed that commad. Then I tried to Copy & Paste, but couldn't do it.


#6

@g4lvy,
-1
Did you try using
a CTRL-c to copy
And a CTLR-v to paste

-2
locale
echo $LANG
stty
should all be on a different line....!!!!


#7

@leonhard.wettengmx.n

Yep, CTRL -c and CTRL-v with no result.

Here the commands.


#8

@g4lvy,
I have invited system-management,


#9

This thread might help:


#10

@leonhard.wettengmx.n

Ok, thank you!


#11

@albionsrefuge

Hey! Nice one!

I could get it through ONLY with the Option 3: Use the on-screen keyboard. Actually, it worked only using the on-screen Characters Viewer and double clicking on the quotation marks!

I've already tried to type the quotation marks on the following exercise, but, with no success as the previous one.

However, I can cope with using the on-screen Characters Viewer for the ones with such a characters problem.

I appreciate your support! thank you!

:slightly_smiling: ]


#12

just type it like this echo "Hello"


$echo "hello": First lesson in input/output doesn't work