Stuck in exercise 4 of 'Deploy your website to GitHub pages' Unit-1


#1

After entering the URL for remote creation, the instructions card doesn't update to go to the next exercise. Th command I'm entering is- git remote add origin https://github.com/karthiknarayan511/karthiknarayan511.github.io.git
Please provide feedback as soon as possible as my exercise is stuck at this stage.


#2

Check if you're in the right directory, maybe you added the remote in a different repository from where it's supposed to be.

What is the output of this?

cat ~/workspace/daw/*/.git/config

BTW, by the time somebody is reading your post, they are probably looking to help. Saying anything along the lines of "asap" can easily make people change their minds.


#3

Hi. I ran the command you sent. This was the output:
fatal: Not a git repository: .git
How do I proceed from this?


#4

Thanx for the help. I created a new repo and that worked.


#5

what exactly u did? I mean how did u solve the problem


#6

I finally solved it
so the command pwd will help you find where you are in a filesystem directory
and the command ls will tell you what files you have in a directory.
anyway...
keep going down using cd personal-website
and then cd .git
and down to configure folder
and use the command given like git remote add thing...


#7