Stuck at 5/6

I can not find anything wrong in my require(’./Child’); but I get following error message
Make sure that you require(’./Child’); on line 3.

<Below this line, add a link to the EXACT exercise that you are stuck at.>
https://www.codecademy.com/en/courses/react-102/lessons/stateless-inherit-stateful-intro/exercises/stateful-parent-component?action=resume

<Below this line, in what way does your code behave incorrectly? Include ALL error messages.>
I get following error message:
Make sure that you require(’./Child’); on line 3.

```

var React = require(‘react’);
var ReactDOM = require(‘react-dom’);
var Child = require(’./Child’);

React.createClass({
render: function() {
return

;
},

getInitialState: function () {
return { name: ‘Frarthur’ };
}
});

<do not remove the three backticks above>

Your code looks right. Sometimes I find it helps to copy the error text and paste it into the code. Weird bug…

var React = require('react');
var ReactDOM = require('react-dom');
var Child = require('./Child');


var Parent = React.createClass({
  getInitialState: function () {
    return { name: 'Frarthur' };
  },
  
  render: function () {
    return <div></div>;
  }
});

This revised version worked for me!

Thanks!
It worked for me too.

Thanks! I copied the code from another answer.

Thanks!
I have found mistake. it’s mycase it was line 10 i returned tags

instead

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.