Stuck at 32% on the Command Line


#1

when i type "cp * satire/" and then the phrase "bash: cp*satire/: No such file or directory"
Can anybody help?


#2

The error message looks like it is suggesting that you didn't leave spaces. Did you? Can you show us a screen shot with the error?


#3

I've added the pic)


#4

Thanks, and that does confirm that you've left out all the spaces in that cp command. Bash thinks that you are asking it to find a command called cp*satrire/, and it is telling you that it is not aware of a command by that name.

Looking back at your touch command, it looks like you have created a new file called shrek.txt. instead of a file called shrek.txt


#5

Thank you for your answer, i did but it's the same result(


#6

Please show me another screenshot so I can see what you are doing now.


#7

Gd morning!)) I've added a new pic)



#8

Thank you for the image. You are still not putting the required spaces in your command.

cp*satire/ is not all one word.

cp means copy
* means everything you see in the working directory
satire/ is where you want everything to be copied to

When you squish those three things together like you've done, it is not meaningful.

Put spaces in, put them exactly where the Step 3. example shows you.


#9

Thank you a lot of!)))) I understand now, i miss the space. It's correct now :blush:


#10

pls can you tell me how you put the spaces betweeen cp * satire/ seems theres a bug


#11

type cp_*_satire/
"_ " it's a space, press a button "Space"


#12

3 posts were split to a new topic: Manipulation > 6.cp II "cp: cannot stat '*': No such file or directory"