[STUCK] [4/9] Step 1: Pasted the code, editor seems to be checking main.scss with .css syntax


#1



https://www.codecademy.com/courses/learn-sass/lessons/hello-sass/exercises/nesting-sass


After running, I get an error:
Did you nest and apply the properties to .slogan?


@import url(https://fonts.googleapis.com/css?family=Pacifico);
//Add variables here:

h1 {
  font-family: Roboto, sans-serif;
  text-align: center;
}

.banner {
  font-family: 'Pacifico', cursive;
  height: 400px;
  background-image: url("lemonade.jpg");
  .slogan {
    position: absolute;
    border: 4px solid black;
    top: 200px;
    left: 25%;
    width: 50%;
    height: 200px;
    text-align: center;
    span {
      font-size: 24px;
      line-height: 200px;
    }
  }
}

.container {
  text-align: center;
  font-family: 'Pacifico', cursive;
  .icon {
    display: inline-block;
    margin: 2%;
    border: 4px solid black;
    font-size: 32px;
  }
}


#2

Hello! so i have been tinkering around a bit to see why you may have been experiencing this.

the only way i was able to replicate this result was by resetting the exercise and then trying to continue the project on 4/9.
resetting the exercise resets it from the very start. (even though you are still viewing 4/9).
to correct this issue, I found that going to section 2/9 and re-entering the scss command in the terminal fixed this problem.

hope this helps! :grin:


#3

Thank you so much, I would've been stuck with this forever! ._. The spaghetti is real though :smiley:


#4

Worked perfectly. Thanks a lot


#5

Thanks so much. Worked perfectly for me too.


#6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.