Step 10 Bug Makes it Impossible To Continue


#1

None of the exercises work. Sometimes I get an error that reads:

“9/script.py has been moved. This will cause problems with this exercise, please move 9/script.py back to its original location, or reset your files”

The # in script name is the # exercise you’re on.

The exercise it happens on is completely random (is already broken upon resetting progress). I did everything as normal (not even any errors except for the one it forces you to make), so I really don’t think it’s on my end.

I reported this bug and I hope it gets resolved soon!


#2

I get the same error, and can’t get past this step in the course:
Conditionals & Control Flow > Mix ‘n’ Match
https://www.codecademy.com/courses/learn-python/lessons/conditionals--control-flow/exercises/mix-n-match


#3

Yup, same issue here. I was coding yesterday, beforehand it went a tad slow and at Step 10 all of my code got deleted. Tried to rewrite it, same thing happened. Copy-pasted the right code into it (after a quick Google search), clicked run and afterwards it gets stuck in an infinite loop or something. This happened when I reached 33% progress, which also happened to a classmate of mine.
Definitely very annoying considering it prevents you from ever finishing this course, or even this chapter.


#4

I get the same error code


#5

The very same thing happened to me on 7th (last) step of the Taking a Vacation lesson. I am really annoyed since, as well, I can’t go onto another exercise and nothing helps… I

was thinking to upgrade, that might solve the problem, but I am not sure…

What do you guys think? Has anyone solved it yet?


#6

I too have the issue. Any solutions?


#7

This problem is on codeacademy’s end. This will probably not be fixed until the amkers of this website see this problem.


#8

i have the same problem


#9

problem anyone getting this also as a problem?


#10

yes me… i want to continue and i cant :frowning:


#11

i went ahead and reported the issue and im hoping it gets fixed also


#12

i reported 3 times from last night


#13

I have been facing the same issue…not able to go beyond Step# 10…please suggest…


#14

yea i reported it 3 times nothing happened so far . i cant move on . what a pity .


#15

same issue for me as well


#16

i want to continue and i cant


#17

Uncaught (in promise) TypeError: Cannot read property ‘code’ of undefined
at platform-034a4acc1f70869ecd17.js:21
at nrWrapper (math?action=lesson_resume:7)
at < anonymous >

This is the error that pops with it


#19

Experiencing the same problem. I reported the issue. Hopefully Codecademy will notice and fix soon. As of now, just stuck on #10.


#20

Same problem. Reported this nearly one week ago and no answear :frowning:


#21

Same problem here. Hope they will fix it.