Start Local Server: Preview your site locally


#1

Hello all i am stuck at this....don't know why this is not working.
Any help is appreciated.
i can see the files using ls
jekyll serve
Configuration file: none
Source: /home/ccuser/workspace/daw
Destination: /home/ccuser/workspace/daw/_site
Incremental build: disabled. Enable with --incremental
Generating...
Build Warning: Layout 'post' requested in my-portfolio-si
te/_posts/2016-09-28-welcome-to-jekyll.markdown does not exist
.
Build Warning: Layout 'post' requested in my-portfolio-we
bsite/_posts/2016-09-28-welcome-to-jekyll.markdown does not ex
ist.
Build Warning: Layout 'post' requested in personal-websit
e/_posts/2016-09-28-welcome-to-jekyll.markdown does not exist.
Liquid Exception: Included file '_includes/icon-github.html'
not found in personal-website/about.md
jekyll 3.1.3 | Error: Included file '_includes/icon-github.ht
ml' not found

where did i go wrong?


#2

Jekyll seems to be saying your files is in bit of a mess doesn't it?
Maybe you started it in the wrong place or need to re-generate the files


#3

Hey there,
Make sure that you enter the correct command. First two lines below.
If you still encounter an issue, I suggest you go back at the beginning of the course and start it over. ( 1h ago,I was stuck at the same spot as you are and I just decided to restart from the beginning and now it works fine. Probably an issue with a typo or something like this).

$ cd personal-website                
$ jekyll serve
                                      
Configuration file: /home/ccuser/workspace/daw/personal-website/_config.yml                                         
Source: /home/ccuser/workspace/daw/personal-website                                                
Destination: /home/ccuser/workspace/daw/personal-website/_site                                    
Incremental build: disabled. Enable with --incremental                                                      
Generating...                                                     done in 0.483 seconds.           
Auto-regeneration: enabled for '/home/ccuser/workspace/daw/personal-website'                           
Configuration file: /home/ccuser/workspace/daw/personal-website/_config.yml                                 
Server address: http://0.0.0.0:4000/              
Server running... press ctrl-c to stop.