SQLite installed but 'No such file or directory' found

Hello! I am brand new and do not know what I am doing wrong. I have a windows laptop.

I am working on this: https://www.codecademy.com/courses/learn-sql/articles/what-is-sqlite.
Here are the steps:

  1. Download the sqlite-tools-win32-x86-3200100.zip file and unzip it.
    2.From your git-bash terminal, open the directory of the unzipped folder with cd ~/Downloads/sqlite-tools-win32-x86-3200100/sqlite-tools-win32-x86-3200100/ .
  2. Try running sqlite with the command winpty ./sqlite3.exe . If that command opens a sqlite> prompt, congratulations! You’ve installed SQLite

To start I did not have ‘git-bash’, so I followed the instructions here to get that on my laptop: https://www.codecademy.com/articles/command-line-setup.

So, when I go do the first step, this is the result: ‘No such file or directory’

I got on the forums and I was told maybe the version has been updated, and to check it is in the right folder and unzipped. It is in my downloads folder and extracted (is that unzipping?). They then told me to pull the unzipped file into gitbash, so I did and when I do that the directory is found.

So next I tried the 2nd step after the directory says it was found, to enter ’ winpty ./sqlite3.exe, but it just says ‘no such file or directory’ also.

What am I doing wrong? Please help!

(Here is an overall screenshot of the three scripts I tried, in order):
image

Thank you in advance! :slight_smile:

It might be worth taking a course on using the command line. It’s used for so many things that it’s hard to avoid entirely; it takes a little learning to get used to it but is likely well worth the time investment.

The instructions here are perhaps overly specific and the standard version for sqlite has since changed. This means the filepath is different in this case. So you can either change to that directory and run sqlite3.exe or try and run it directly. To stick closer to the instructions for now try:

First change into the relevant directory:
cd ~/Downloads/sqlite-tools-win32-x86-3360000/sqlite-tools-win32-x86-3360000/

Then try running the winpty command using the sqlite3.exe file in the current directory:
winpty ./sqlite3.exe

You were almost there but you needed to preface the directory path you copied with cd to change into that directory before attempting to use the actual .exe file.

1 Like

Wow thank you so much, that worked! Thank you for suggesting I take a course on using the command line. I am going to do that for sure.

Thanks again, you’ve been such a huge help here and in discord!

Sincerely,
Bethy

1 Like