Spinning wheel - Ruby lesson doesn't work


#1

See image. There is a spinning wheel in the Ruby lesson and the buttons to save and submit code don't work. I tried both Safari and Chrome browsers, logging out and in, refreshing, and deleting codeacademy cookies in Safari. This website shows that codeacademy is up http://www.isitdownrightnow.com/codecademy.com.html (and in fact the buttons for navigating in codeacademy work, such as viewing the status of completing lessons). I tried several places in the Ruby lesson, all spinning wheel. A Google search indicates that this is a recurring problem over some years.
Safari v 9.1.1, OS X 10.11.5, macbook pro.


#2

I think I figured out the solution.. The Instructions say:
"Check out the code in the editor—we've added some new things that we'll be teaching you. Can you guess what it does? Click Save & Submit Code to find out!"
But this didn't work. The Save & Submit Code button was inoperable.
However, by clicking on the bottom left button (in this case "1. What You'll Be Building"), the buttons were enabled.

Two suggestions to codeacademy:
(1) either fix the spinning wheel or change the directions so they reflect what you can actually do to proceed
(2) I don't see a button on the codeacademy homepage to report problems or view this forum (had to use Google to find it). If it's not there, add it.

thanks.