Services II "use date to format datetime


Hi, I have been trying to figure out this error for a couple of days now, it tells me to use "date" to format datetime. I did this in multiple way, ( fiveDay.datetime | date, date | fiveDay.datetime, day.datetime | date, days.datetime | date) among others. Continue to get the same error. at one point got it to get past the date, but got other errors with the next sections, and when I changed things there, it went back to giving the datetime error. I've looked through the other postings here about this section, and made the changes that were suggested from others, and worked for them. However, it has not worked in this program. Is this a bug? Have I missed something?


Hey @ryanmullins It might be the extra formatting you've added. I don't think you need the

Take a look at @vesela1 screenshot over at I found this helpful.


See I worte the same code but the format of my output is different. How..?


I was getting this problem too. The city name wasn't displaying and I couldn't progress past step 2...

However when I selected "I want to restart this exercise" option under the "Get Help" button, once it had completed the reset the city name was displayed, and running the code again by clicking RUN worked.

Go figure...


Having the same problem. None of the above solutions are working. please help!!!


Same here, still not working