Seems I pushed my repository to GitHub but can't see it

Hi everyone,

I just finished a challenge project in my JavaScript course and - following this article here Number Guesser Challenge Project (JavaScript) - and this article: https://www.codecademy.com/articles/getting-started-git-and-github I wanted to push my local repo to my github account.

I did everything as described but when I want to push my local repo to Github it
a) does not ask me for user and pass and
b) I can’t see it online in the folder

If I want to repeat the process by using

git remote add origin https://github/myuser/git_practice.git

it returns an error message telling me that the origin already exists.

So when it exists, why can’t I see it?

Hello @philippkowalski80717

Did you push the files to the remote git?

Command (depending on your main branch):

git push -u origin master

OR

git push -u origin main

Thank you @adriansomor

I tried both and both give me an error message:

git push -u origin main

results in

and

git push -u origin master

gives me …

The latter one seems to be interesting because it didn’t ask me for my GitHub user / pass.

Have you stored your credentials somewhere, like done here:

https://stackoverflow.com/questions/35942754/how-to-save-username-and-password-in-git

then it would explain why you weren’t prompted for a username/password. You could update/remove the credentials?

4 Likes

Now it worked.

It opened a browser window (while I was logged in to GitHub in that same browser on another tab) and asked me to provide access to the GitBash application.

I granted access and then it pushed the localrepository which is now also available on GitHub.

Thank you all! :slight_smile:

1 Like