SCT error in this code


#1

squares = [x**2 for x in range(1, 11)]
print filter(lambda x: x >= 30 and x <= 70, squares)

https://www.codecademy.com/courses/learn-python/lessons/advanced-topics-in-python/exercises/try-it?action=lesson_resume


SCT Error in Part 11
#2

What is the error you are being alerted to?


#4

i got the same problem , keeps showing “SCT Error” but the code seems to be correct


#5

Hi, I’m getting the same message for a code that looks correct and provides the right result

Is there a bug or something making this SCT error?


#6

This is accepted without any indicatioin of error…

squares = [(x + 1) ** 2 for x in range(10)]

print filter(lambda x: 30 < x and x < 70, squares)

Not sure why you are gettting an error since your code is fine. Still waiting to read the error message.


#7

I have this SCT error as well. I think my codes are correct .

squares = [x**2 for x in range(1,11)]
print filter(lambda y: y >= 30 and y <= 70, squares)


#8

Hi mtf,

To be clear, the error literally says “SCT Error.” That’s it. We’re blocked from doing anything else because we can’t get past that error.

Thanks,

Jay


#9


#10

Is this an Edge only issue, I wonder? I use FF and on rare occasions Chrome.


#11

Experiencing the same issue. Using Google Chrome on macOS Sierra. Thanks!


#12

Anybody weighing in, please do us the kindness of describing your system’s OS and browser. Thanks.

Win7, etc.
Firefox, etc.

This will help CC engineers zero in on the problem.


#13

I’m getting the same error as well. Using Chrome on a Windows 10 OS with the following code:

squares = [x**2 for x in range(1,11)]
print filter(lambda x: x<=70 and x>=30, squares)

What I think is the right result is printing to the console: [36, 49, 64], but then the code editor displays ‘SCT Error’ on the bottom and won’t let me move on.


#18

well i am using Google Chrome on widows 10
as you can see here:


#19

That makes 2 on Chrome, Win10. Both with the same issue. Starting to get somewhere.


#20

#26

Same thing on Windows 7 and both Google Chrome and Firefox


#27

FYI, Recently the course name has changed from Python to Learn Python. Along with this, UI has totally changed in this version.
Also, few of my friends had the same code in their older version and it really worked for them.
Now, why is this SCT (Submissive Correctness Test) Error is coming after the change of UI ?

I tried working on many browsers, tried resetting the code and even tried to work on different system… Nothing Worked !
Is this the bug in this newer version???

Please suggest some solution asap.


#28

Same problem. Google Chrome


#29

Same Problem on Safari


#30

Same Problem on Win 7 and Firefox browser