Script.py has been moved error message

Thank you for the response. Still sucks that the issue exists and it’s frustrating having to stop and start while trying to learn Python. BUT at least it is good to know that the issue is acknowledged and known. Hope this gets resolved soon because codeacademy is usually a great resource and I would like to use it more in the future.

I can’t do anything about it? Going back doesn’t work for me. I’m stuck on one exercice and I can’t advance, whatever I do.

I think that some how the editing file(the one you type in) hase been moved but i don’t know where or how to move it back i just know that you can check if you klick on the file icon above the code editor find the corresponding number to the exersize you can check
DISCLAIMER
I’m only guessing with my limited knowledge

yup i am facing same problem. Is there any solution for this?

I’m having the same issue too, and infuriatingly the “report bug” link currently doesn’t work for me either :weary:

I was facing the same problem but after some tinkering I managed to fix it. All you have to do is go back a lesson and then reset your files and go back to the one you were working on. I also looked into the html code to see what was going on and I found 4/script.py it didn’t seem to have moved. I dont know much html but if anyone else is more experienced please try it out. To find it I opened the source code of the website went to debugger, www.codecademy.org then an url that started with courses then the lesson I was on and searched for 4/script.py.

I have the same problem, it started a few days ago, and wont let me do anything except pointlessly ‘resetting my files’.

checked back again today (after just leaving the whole site for a few days in the hopes it would be fixed) and I’m now getting the same issue, but somehow worse. When the script tries to reset it now clears the screen where I know there should be pre-done python, and also does the same if I go back a lesson and try loading it again.

anyone getting any responses from support?

I deleted my browsers cookies and cache and it seems to work. Maybe try that? Also I somehow gained access to the scripts, I deleted my cache and cookies and hit next and then a file folder popped up which showed all the scripts.

i tried that, and it seemed to work for a while. I’m no longer getting the same error, but now when I reset the exercise it doesn’t pull in all the code that it should

I had that too, the only thing that fixed that sometimes was to log out then in again, but it only works sometimes. I was getting frustrated with that today, so I tried a different browser, Google Chrome, and it went very smoothly on there. I managed to get 2 lessons done without any problems on chrome. Also, do you know why its happening.

I also have the same error message. However the code on the last screen now stays on every task no matter how far back I go. In addition when I do run the "working code"the run button just spins not doing anything, meaning I cannot complete the task. Any help is appreciated.

1 Like

Same problem as @12whiteleggj, any workaround?

same problem. codecademy can i please move on to the next lesson?! pls my assignment is due tomorrow!!! begssss

Same issue for lots of students in my class. Not cool. Please fix this!

1 Like

Solved (for me). I’ve been dealing with the same issue as everyone above. This is what I did to fix it:

Browser: Chrome Version 60.0.3112.113

  1. Close all tabs
  2. Clear cache and cookies
  3. Open new tab, open codecademy to the lesson plan with issues
  4. run a hard refresh (ctrl + r)
  5. voila! it works
3 Likes

Am frustrated, tried out all the above but all in vein,
please help.

Hey all, I had the same issue, but after clicking the reset button I was able to re-type my code, run it and move forward. The reset button is right next to the “Run”.