Save & Submit is just spooling... doing nothing. No error, No approval of code


#1

Ruby: Putting the Form in Formatter: 2. Prompting the user.

My code looks like this:

print "What's your first name?"
first_name = gets.chomp
first_name.capitalize!

I hit "Save & Submit Code" and the wheel just keeps spooling (I've left it to do this for a couple minutes, thinking that the system could just be overloaded, but it just keeps doing this). It does not report an error, nor does it say "Good Job!" and allow me to continue to the next lesson. It just gets stuck. I can refresh the page, close the browser and open a new one, reset the code and rewrite it, but nothing seems to be working... Please help.


Save & submit button problem
#2

Hey Alexander,

Are you typing text in the blue highlighted terminal prompt thing on the right of the page after submitting your code?
A common mistake people make in this course is not realizing you have to type some text, then press the Enter key before you can be passed :slight_smile:


#3

Are you referring to the command prompt? Because there is nothing there UNTIL I try to save and submit my code... After I've done that (& as I explained above), I don't have the option to do anything else, as the processing wheel on the "Save & Submit" button just continues to spool. I tried your suggestion, but because the button is still spooling, there is nothing I can do... ?


#4

Hi Alexander, could you please post a screenshot of what you're seeing?


#5

No problem, here you are....


#6

And here is the screen shot PRIOR to hitting the "Save & Submit" button... You will see that there is no prompt in the command line (presumably because I have not submitted my code yet).


#7

It worked perfect for me. Try using a different browser for this exercise.


#8

Yes, once I pasted the link into Firefox and tried it there, it went through just fine. :confused:

I've been using Chrome for every one of my lessons, so I didn't think that could be the issue, but it certainly was... Thanks Chris!! (And thank you as well Zeke)


#9

Hey,

I am experiencing the same issue last two weeks. I am coding and when I hit "save & submit code" button it just stuck. No error, no option to continue no anything. If I refresh the page code appear incomplete.

Sometimes when I finish my code a can still see some syntax errors in lesson sidebar with code results. When this happened, above reported problem happen also. It looks like code is not saved in some random point. It do not depend on some concrete code or course.

Solution with firefox did not worked to me :frowning:

Do you have any more ideas please?


#10

@methodrunner74275 Could you post a screenshot of what you're seeing, before pressing “Save & Submit Code”, and after?


#11

Hi Libor - sorry, I am just now seeing your message. Another thing that could be the issue is that your browser is outdated. That code is exactly correct and should work. After pasting my code into Firefox and putting it through, I ended up having to go back and update my Chrome browser because I had the exact same problem on the next lesson (as I default to Chrome). Once I did that, the issue went away. Hope that helps..


#12

It looks that browser update worked :slight_smile: Thank you!

If it appers again I'll be back with screenshots


#13

If it does happen again, or you have another problem, please create a new topic.

Thanks.


#14