Run button does not work (learn python course)

Hi everyone,

After a long break I resumed the python course today and it seems the run button is not working. When I click on it, nothing happens. I found someone having the same problem and this person solved it by changing the browser. I tried it with chrome and firefox now but still no result.

Does somebody know what to do in this case?


I have the same issue if I leave the browser open to a lesson for too long without doing anything. Just refresh the page.

Hi objectrockstar80326,

thanks for the answer - i already tried that too in both browsers but it did not solve the problem :open_mouth:

Hello @maresi, could you possibly post a screenshot of the problem? Thank you. :slight_smile:

Hi intermediategamer,

screenshot attached - after clicking the “run” button the type is replaced by the loading animation for one or two seconds.


Hmm, that is quite unusual. :thinking: What browser are you using? I saw that you said:

When you took this screenshot, were you using any of the two browsers mentioned above? or did you try a different browser this time?

1 Like

yes the screenshot was taken when i used chrome, version 59.0.3071.115, and my firefox is 29.0.
I was quite surprised too, this never happened before :smile:

1 Like

I’ve seen it, but it’s never happened to me before. :smile:

Here’s what you should do:

  • You should file a bug report :bug:

Here’s what I’ll do:

  • I’ll ask around the forums :slight_smile:

Currently, the Python courses are a little “buggy”, but the Codecademy team is working on it and they’ll be fixed soon. :wink:

1 Like

thanks for the advice, I already reported the bug. :slight_smile:
hah yeah I saw that I am not the only one having troubles with the python course when I was looking for similar topics in the forums :smiley:
Thank you for the help so far - then I will wait a little bit

1 Like

Yep, you’re welcome! :+1: And thanks for your patience. :smiley:


Hmm. I’m facing the same issue. I’m on “plan your trip” question, It is been 2 days i stuck on the problem. Run button seems like not working.