Ruby - Putting the Form in Formatter - not working


#1

Hi, doing the intro to Ruby on rails course and stuck at 6% on the "putting the form in formatter 1. What you will be building" part of the course. I have tried using a Mac computer instead of windows, restarting my computer, I have tried deleting my cache, turning off pop-up blocker and turning off my firewall. None of those have worked.

Any advice would be greatly appreciated!


#2

Just to clarify, when I complete the section with my personal information and click submit it just gets stuck loading rather than going red or green. (red being an error and green being the correct answer which then allows you to the next page)


#3

That image is almost impossible to read. Could you please post your code? It looks like the variable names don't match:

first name = gets.chomp
first_name.capiltalize!

last_name = gets.chomp
last name.capitalize!

is what it looks like. We'll be able to confirm this when you post your code.


#4

print "Julia"
first_name = gets.chomp
first_name.capitalize!

print "Surname"
last_name = gets.chomp
last_name.capitalize!

print "City"
city = gets.chomp
city.capitalize!

print "State"
state = gets.chomp
state.upcase!

puts "Your name is #{first_name} #{last_name} and you're from #{city}, #{state}!"


#5

All I change is adding in my details but when I click run it doesn't pop-up with the red writing telling me it is wrong or the green writing telling me it is correct. It just shows the white loading symbol. I have been reading the forum and it seems that other people are having the same problem here and in other places on the intro to Ruby course. I looked on the Code Academy troubleshooting page which suggested it was a problem with my internet firewall. As mentioned in previous posts I have tried to fix this but it hasn't worked.

I can go to the next page by clicking the menu icon (three lines) and then choosing the next chapter. I am able to complete "Prompting the user" but the same problems occurs on pages "getting input" and "repeat for more input".

I need to complete an intro to coding course to prepare for a 3 month intensive coding course that I am doing. As this website is not working I have started to use CodeMonk. I really liked Code Academy as it has a great interface but sadly it won't work on my computer.

If anyone has any advice I would love to find a way to fix it!

Julia


#6

Please post a link to the exercise, along with any error message you are receiving. Thank you.


#7

https://www.codecademy.com/courses/ruby-beginner-en-MxXx5/0/1?curriculum_id=5059f8619189a5000201fbcb

Putting the Form in Formatter 1. What you'll be building (link above)

No error message but when I click "run" it changes to a white wheel/symbol which is rotating as if loading. It then never progresses to say if it is right or wrong.

I know that the image isn't great but I have added the image of the page with my text and the loading symbol in the bottom left hand corner


#8

Seems to be working alright, just now. Try a Ctrl F5 refresh. I would also recommend Reset the first lesson. It is an example, not an exercise. Just run the page and provide inputs at the four prompts.


#9

Doing ctrl F5 does refresh the page but that doesn't fix the problem. It returns me to the page and when I press Run the same thing happens i.e. I cannot progress to the next page and I do not know if my code is correct or incorrect, I know it is an example and I did skip it to the next pages but the same thing is happening on other pages meaning that I can no longer check if my code is correct or not.


#10

Then try to reset so you restore original code. Don't change anything; just Submit it.


#11

I have the same problem


#12

I also have the same problem, this chapter doesn't run at all


#13

If anyone needs help with this section:

  1. Go to https://discuss.codecademy.com/c/ruby/ruby-beginner-en-MxXx5
  2. Click + New Topic
  3. Fill in the template
  4. Someone will be along to help

#14