Ruby on Rails Bolt-Network

https://www.codecademy.com/courses/learn-rails/projects/learn-rails_bolt-network

After following the directions in the video 4 times I was still getting sass syntax errors. I followed the error and it lead to the /app/views/layouts/application.html.erb file.
on line 5 before step 9 or line 7 after it the following line exists by default.

<%= stylesheet_link_tag ‘application’, media: ‘all’, ‘data_turbolinks_track’ => true %>

This line once deleted from the code cleared up the problems I was having but also resulted in the final product on the website not matching the example finished product (mainly a white background but still functional). As this is part of the provided code and not something added by the student I just wanted to bring some attention to it.

Thanks

1 Like

I believe I was having the same problem. I searched in the forums and found what I believe is the same problem discussed here:

I am really new, but this is my attempt at an explanation:

Notice the error points to invalid CSS:

Showing /home/ccuser/workspace/learn-rails_bolt-network-2/bolt-network/app/views/layouts/application.html.erb where line #5 raised:

**Invalid CSS** after "...image:url(https": expected ")", was "://content.code..."
  (in /home/ccuser/workspace/learn-rails_bolt-network-2/bolt-network/app/assets/stylesheets/pages.css.scss:2)

The solution provided in that other thread worked for me. Add a ; (semicolon) at the end of line 2 in app/assets/stylesheets/pages.css.scss

Maybe someone who is more experienced can explain how the applications file interplays with the pages css file.

1 Like