Ruby on Rails: Authentication bcrypt problems

ruby-on-rails
bcrypt

#1

Ruby on Rails: Authentication bcrypt problems.
So I wanted to learn about ruby on rails so I followed the lessons through codecademy. I wanted to create my own rails server on my own computer so I followed all the steps but on my computer. Everything worked up until the point where codecademy introduced me to bcrypt. I am on this forum even though it doesn’t completely relate to codecademy’s lessons in particular but nothing on the internet can fix my issue.

My issue currently is when I run the server with “rails server” it throws me an error and doesn’t start the server. This is the error:

C:/Ruby24/lib/ruby/gems/2.4.0/gems/bcrypt-3.1.11-x86-mingw32/lib/bcrypt.rb:16:in require': cannot load such file -- bcrypt_ext (LoadError) from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bcrypt-3.1.11-x86-mingw32/lib/bcrypt.rb:16:inrescue in <top (required)>‘
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bcrypt-3.1.11-x86-mingw32/lib/bcrypt.rb:12:in <top (required)>' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:81:inrequire’
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:81:in block (2 levels) in require' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:76:ineach’
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:76:in block in require' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:65:ineach’
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:65:in require' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.0/lib/bundler.rb:114:inrequire’
from C:/Users/sebas/RoR/config/application.rb:7:in <top (required)>' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/railties-5.1.4/lib/rails/commands/server/server_command.rb:133:inrequire’
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/railties-5.1.4/lib/rails/commands/server/server_command.rb:133:in block in perform' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/railties-5.1.4/lib/rails/commands/server/server_command.rb:130:intap’
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/railties-5.1.4/lib/rails/commands/server/server_command.rb:130:in perform' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/thor-0.20.0/lib/thor/command.rb:27:inrun’
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/thor-0.20.0/lib/thor/invocation.rb:126:in invoke_command' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/thor-0.20.0/lib/thor.rb:387:indispatch’
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/railties-5.1.4/lib/rails/command/base.rb:63:in perform' from C:/Ruby24/lib/ruby/gems/2.4.0/gems/railties-5.1.4/lib/rails/command.rb:44:ininvoke’
from C:/Ruby24/lib/ruby/gems/2.4.0/gems/railties-5.1.4/lib/rails/commands.rb:16:in <top (required)>' from bin/rails:4:inrequire’
from bin/rails:4:in `’

So since I wanted to fix this error I searched “bcrypt_ext Load error”. I clicked on every link and followed what they said fixed this issue but none of them worked. All of them just say uninstall bcrypt then do “gem install bcrypt --platform=ruby” but that give me another error:

ERROR: While executing gem … (Gem::UnsatisfiableDependencyError)
Unable to resolve dependency: No match for ‘psych (= 3.0.1)’ on this platform. Found: x86-mingw32

On google their answers for this error don’t work either.
So basically bcrypt is causing my server to be unable to start because of errors and I want someone who knows what their doing to help me fix this. I have been frustrated for 2 days with this error, no other forums help so hopefully this one does.


#2

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.