Ruby is stuck loading for over a week


#1



RUBY 2. Getting user input


My code:
print "Hello"
user_input = gets.chomp

When I press submit its stuck loading, I have tried many times over the week I am using chrome and have also tried safari. I have managed to work in html in the meantime but really want to keep working in ruby. Is there anyway to fix this? It was working fine until this lesson.


#2

You should be fine. Try using puts instead of print I guess.

Then type something after the Hello prints and hit the enter key.

Hope that helps! :smile:


#3

Hi,
Even when I tried above and press save & submit, the wheel just keeps spinning. It won't load. Have tried exiting, restarting computer using a different browser safari rather than chrome. Can't figure out whats wrong. I even tried using the demonstration code and it wont load the wheel just keeps on spinning.


#4

From the above, you could see it works. I don't know what else to suggest.


#5

Why do you have a different interface? My looks like this and I also have the same issue as imacat2.


#6

Na. The screenshot I used above is of repl.it, an online code editor.

What issues are you having with your code, please?


#7

It’s still loading because you haven’t input anything yet. In the command line just hit enter, or enter whatever string, it should clear the loading.


#8

When I click ‘Run’ everything freezes. I tried to type different commands, tried different browsers and laptops, but nothing works. Here is the screenshot.


#9

I tried to hit enter in the command line or just click ‘Run’ - everything freezes anyway.


#10

I also tried to type ‘puts’ instead of print. Didn’t work either


#11

Sorry you have this issue. Try restarting your system and connection. If it persists, let me know so I tag an admin or moderator.


#12

It would be great if you can tag an admin or operator. I appreciate it.


#13

Did you try entering your name at the input prompt?


#14

Hi ! I also have the same issue. The Run button keeps spinning forever and I can’t get past the lesson.


#15

Same here! I’ve submitted several bug reports


#16

I have just gone back and tried it on my computer, windows 10 and Chrome browser. It is working fine. And, just mentioning that the run and the tick box will keep on spinning until you type something in the console to the right side, where it is blinking. Just type anything and hit enter, you don’t have to do anything in the editor.
Hope this help.