Ruby Console Won’t Load


#1

It’s been a few months since using Ruby, and now the console will not load. I have tried looking at different lessons, but all Ruby lessons do the same thing. I’ve tried clearing cache/cookies, all major browsers (aside from IE as I am on a Mac), and nothing works. The error I get in the browser console is an error loading resource - the XHR request to https://codex.codecademy.com/info fails to load because the certificate for the server is invalid. The initiator is composer_controller-7f25a107b8bdd3c4eda957770e63fcf2.js:35807. Is there anyway to get around this?

Thanks.


#2

I have the same issue. Anyone with a solution for this?
On my Windows laptop it's working fine. But on my Macbook the console won't load due to an invalid certificate.


#3

I just figured out my issue. I have the extension AdBlock Plus. I disabled AdBlock Plus on codecademy specifically, and then it suddenly worked. I’m not sure if you’re using this extension (or even the regular AdBlock extension) but it seems any extension used to block ads may inhibit codecademy’s ability to work properly. Hopefully this is what you’re using so your problem can be solved as well.