Routing II - Keep loading forever

<PLEASE USE THE FOLLOWING TEMPLATE TO HELP YOU CREATE A GREAT POST!>

In the second test, I add the routing for photos/:id , but with it or without it, when I click RUN, it starts checking and never ends. No error, nothing.

Thanks.

<Below this line, add a link to the EXACT exercise that you are stuck at.>
https://www.codecademy.com/courses/learn-angularjs/lessons/routing/exercises/routing-routing-ii

<In what way does your code behave incorrectly? Include ALL error messages.>

3 Likes

I reset the excercise, in case it where something with the code I wrote, but is not working either. I click run with the files as they are after reset them and it just continue loading…

Hi claudio,

Clear your browser’s cookies, or if you use chrome, try to go incognito and rerun it.

It worked for me. Good luck

I’ve already tryied with incognito mode, but wasn’t working either, but as it was working for you, I try Firefox… now I pass the test with Firefox and everything went ok.

Thanks.

2 Likes

For anyone else that’s having this issue. I found a workaround so that you don’t have to use another browser. Navigate to the json source by clicking on the red link and after that click run. You should be able to advance to the next level now :slight_smile:

17 Likes

This worked for me.
Click the ‘https://s3.amazonaws.com/codecademy-content/courses/ltp4/photos-api/photos.json’ link in red in the ‘Learn’ panel on the left hand side.
Then click run.
This got me past the forever loading screen.

2 Likes

I refreshed the mini browser on the ride hand panel, this worked for me, otherwise it just looped forever.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.