Routing I: image gallery not showing up


I'm stuck on 1/4 of the routing tutorial for Angular JS (Link Below)

I've followed the instructions exactly with no warnings appearing and the tutorial will let me continue to the next section. In the browser I see a red logo, some text that is not in English and a black square that says 'recent photos'. From looking at others screen shots of the same page a number of images should be showing below, but they do not. I have tried refreshing the page and also seeing the full code provided by Codecademy but in neither case does the image gallery show up! I've included some screen shots to help explain what is happening along with the code I've entered for both index.html and app.js.

Has anyone else had this issue? I'd greatly appreciate any guidance anyone can give me!


Please paste your HomeController.js and home.html view so we can help you :slight_smile:


Thanks for replying! I've pasted them below :slight_smile:


app.controller('HomeController', ['$scope', 'photos', function($scope, photos) {
  photos.success(function(data) {
    $ = data;


<div class="main">
  <div class="container">

    <h2>Recent Photos</h2>
    <div class="row">
      <div class="item col-md-4" ng-repeat="photo in photos">
        <a href="#/photos/{{$index}}">
          <img class="img-responsive" ng-src="{{ photo.url }}">
          <p class="author">by {{ }}</p>



I have exactly the same problem and when I copy paste the code in my text editor, I have an error :

Error: [$injector:unpr] Unknown provider: photosProvider <- photos

Apparently a 'required dependency' issue but I'm enable to solve that for now despite my research, do you have an idea ?


I am getting the same problem. I am unable to see the photo gallery. In console I got this error:

Mixed Content: The page at '…ng-routing-ii?action=lesson_resume&link_content_target=interstitial_lesson' was loaded over HTTPS, but requested an insecure stylesheet ''. This request has been blocked; the content must be served over HTTPS.

Any solution for this?


Got the answer :joy:

Changed content of "photo.js" by replacing "http://" to "https://". That's it.


Oh, yes indeed, Thanks !


That worked. Thanks.


Yep, fixed! Thanks very much.


thanks, it works with "https://"


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.