RIght Code but Page won't let me continue


#1

Can anyone see anything I am doing wrong? I don't think that the issue is with my code but I don't know what to do to move on.

My CSS is:

h1 {
font-family: Verdana;
color: #576D94;
}
p {
font-size: 18px;
color: #4A4943;
}


#2

Firstly, could you include the HTML code aswell? There might be a problem in there.
Secondly, what exercise out of the 26 exercises are you stuck on? And what does the error message say, do you even get one?
If you include that people can help you.


#3

I'm not on that one anymore. The problem on that one wasn't with my coding but with the codeacademy platform. Now I am having the same issue on another one.

Exercise 26.
(MY HTML)








Money doesn't grow on trees.


HELP ME!!!

But apparently trees grow on money.



(MY CSS)
h1 { font-family: Verdana, sans-serif;
color: #576D94
}
p { font-family: Garamond, serif;
font-size: 18px;
color: #4A4943
}
img { height: 100px;
width: 300px;
border: 1px solid #4682b4;}
a { text-decoration: none;
color: #cc0000;}


#4

To present your HTML-code without the EDITOR interpreting use
= http://discuss.codecademy.com/t/im-having-a-problem-on-lesson-11-23/2307/2


#5

There's a semicolon ( ; ) missing after color: #576D94 and color: #4A4943.

h1 { font-family: Verdana, sans-serif;
color: #576D94                                            <-right here
}
p { font-family: Garamond, serif;
font-size: 18px; 
color: #4A4943                                            <-and here
}
img { height: 100px;
width: 300px;
border: 1px solid #4682b4;}
a { text-decoration: none;
color: #cc0000;}

Don't forget to place a semicolon ( ; ) after every command.


#6

@dutchc0de,
@lizajanelong,

As you can read in
= https://developer.mozilla.org/nl/docs/Web/CSS/Voor_Beginners/Selectors

  • The semicolon after the property-value pair separates it from other property-value pairs in the same declaration

As the property-value pair is the last in the declaration
a semi-colon is NOT needed,
as you have nothing to separate this property-value-pair from.

So IMHO that would not be the problem......


#7

Thank you for your help. It is still not working.

Yes, the semi-colon is unimportant if it is the last declaration. I did try putting them in just in case the platform is very moody. It still does not work. As my html was displayed with the wrong format above, I am reposting it below.

MY HTML:

MY CSS:


#8

OH WOW!

I just figured it out. Thank you all for your help. My code that linked my html to my css was wrong. I feel so dumb. I spent so much time trying to fix my css and nothing was wrong with it.


#9

@lizajanelong,

In your

<img src="http://.....jpg" />

insert a =space=-character before the />
this seems to be mandatory in XML and is used as syntax-specification by codecademy....

The same goes for your

<link type="text/css" rel="stylesheet" href="stylesheet.css" />

( notice a space-between-link-and-type, AND no semi-colons-; )

Try those changes....
and if you have further problems it would be nice to know which section we are exactly writing aboot...