[Reported] Font Awesome Lesson

I’ve encountered a small issue with this lesson.


The link provided in bootstrap (https://stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css) doesn’t match the one requested in point 2 of the lesson and I get the error “Did you add a link to the maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css path in the”.

Tried using the one in error (“maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css” as I tought maybe the link was outdated) but still got the same error msg.

Am I wrong here? Anything off on my code?

Hi there.

I noticed a few weeks ago that, in some of the lessons which expect Google Fonts linked stylesheets, the lesson environment was testing for old variations of the links (based on an older version of the API).

If you can leave this with me for a little bit, I’ll see if I can re-create your problem and get back to you.


Hi @tera5733433914

Thanks for waiting.

Yeah, the learning environment doesn’t like the submission if you’ve used the new URI for the Bootstrap CDN (https://stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css)

From what I’ve been able to find, the change from “maxcdn.bootstrapcdn.com” to “stackpath.bootstrapcdn.com” is a superficial one - MaxCDN being acquired by StackPath as best as I can tell. Both URIs still work, which you can verify by visiting the URI for the CSS file (https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css)

I presume that the intention is that you’ll copy the URI for the CDN from the instruction panel in the learning environment… but, I’ll flag this with CC anyway and see if they can either update the environment since the URI has changed.

Thanks for reporting it. :slight_smile:

1 Like