[reported #34] 7. font-size: 2rem; fails despite being correct

Still not working. I have not changed the padding on this lesson.

The last lesson probably didn’t pick up the error now it did…

Try removing it

I did remove it, still not working…

what error are you getting ?

I was using chrome there was error but I switched edge I passed

1 Like

Did you add a font-size of 2rem for the p selector in main.css? This is the same error I have been getting…

After switching to IE it worked by the code is EM not REM

try changing to 32px instead of 2rem, it worked for me.

1 Like

Thank You katmcole, it worked and we were stuck on it for a long time

Hi designwhiz35729!

Thank You! If i put px instead of rem - it works!))

I also have this problem.

Section looks like this:

p {
font-size: 2rem;

…Had no problems before this point, inserting code does not help.
I am using Firefox on Ubuntu 14.04, and am unwilling to use any other browser/OS

Here is the rest of the main.css

body {
height: 100%;
margin: 0;
text-align: center;
width: 100%;

h1 {
font-size: 32px;
font-family: Palatino, ‘Palatino Linotype’, serif;
color: rgb(121,149,117);

h2 {
font-size: 56px;

.hero {
padding: 250px 0;
margin: 30px;
font-family: ‘Trebuchet MS’, Helvetica, sans-serif;

p {
font-size: 2rem;

.hero a {
color: #00FFAA;
font-size: 24px;
text-decoration: none;


Can you tell me what error you are getting?

This lesson keeps giving me an error even though i’ve clicked on get code
p {
font-size: 2rem;
why dose it not work

Could you paste in your entire CSS so i can help you


I had this problem too I swtiched browsers (i was using google chrome) and switched to internet explorer and it worked.

1 Like

I am also facing the same problem in p selector

Hi all.

I was having the same problem. I was using Chrome for my browser. I changed to Edge and it worked.

I’m using Chrome and it gave me the error too, very positive I did it correctly since i quadruple checked the entire code and saw here that placing 32px in place of 2rem would fix it and it did!
It also checked off the last instruction on changing the font size property in the .hero selector.

HI everyone, if nobody passes this, I suggest keep clicking run, til new window like confirm window, offer you to keep trying, or get code, just click on get code, and it will allow you to pass, even though you did not get it right, you are right and its bug, so long time and never fixed, I did reported as bugs. Good luck on next lesson!

This is still an issue.

It fails in chrome but if you copy and paste the exact same code to Edge it works.