[reported #18] Lesson 8.1 - checkpoints pass before code submitted

can-not-reproduce
make-a-website
bug-reported

#1


https://www.codecademy.com/en/courses/make-a-website/lessons/closer-look-css/exercises/background-image

Hello,
I have added a background image like it was told in 8.1. and I clicked on "run". The exercise 8.1. was marked as correct, but somehow the exercise 8.2. was skipped and it was marked as correct too.
So I didn't even had to insert this code line : background-size: cover;

I think it is a bug. Did anyone had this problem too?

.hero {
padding: 250px 0;
margin: 30px;
font-family: 'Trebuchet MS', Helvetica, sans-serif;
background-image:
url("https://s3.amazonaws.com/codecademy-content/projects/make-a-website/lesson-2/bg.jpg");

}

`


#2

It sounds like a bug that has been reported already but for a different exercise. I will add yours to the issue.

Thank you for taking the time to let us know. :green_heart:


#3

The engineers are reporting that they can no longer reproduce this bug. A recent change in test code for this exercise may have inadvertently fixed this bug.


#4

I have resetted and restarted this exercise 8.1. and I have tested it now. Unfortunately, I am still getting the same bug :confused:


#5

Please post a screenshot showing the problem so we have something to show the engineers.


#6

it is the same screenshot from my post:


#7

Sorry about that, I didn't look closely, and just assumed it was someone else posting.

Could you try using the "restart" option under Get Help? -- oh never mind -- I'm really not doing well with reading comprehension tonight!

I've re-reported this. I'll post anything that I find out.


#8

:grin:
yeah I used the restart option under get help... I have tested it now three times :heart_eyes:
lucky me I can do Unit 3 and some of Unit 4 again, because my progress was deleted :smiley: I thought only exercise 8.1. will be deleted :open_mouth:


#9

Which operating system and browser are you using?


#10

I am using Windows 8.1. and Firefox
I have completed and finished the "Make a Website" course yesterday ... everything worked fine for me :slightly_smiling: ... only this exercise 8 didn't work like it should ... maybe other codecademy users didnt have this bug ?


#11

We are having trouble reproducing this problem so that makes it hard to fix. :slightly_smiling:


#12

I am stuck too! what do I need to keep going? I did all the changes and it does not recognize it!
Thanks


#13

What you are describing doesn't sound like the same problem as this one. Please start a new thread for your situation.

Include:

  • screenshots showing the problem
  • your operating system
  • all of the browsers that you've tried
  • if you have a firewall
  • if you are on a home/school/work network

#14

Hi AJ,

The engineers can not reproduce this problem so they are unable to work on a fix for it.


#15

thank you for your efforts :heart:


#16

I am currently having the same problem. No image! I was checked like everything was ok but a image never came up.


#17

It's got something to do with the image url. I just found my own image and copied the image adress and BOOM! It worked like a charm.


#18

When I paste the examples url I got nothing but after posting my own image I could then recopy and post the example image and it would work just fine.