[reported #139] Connecting to Codecademy (canyu)

bug-reported
bug-profile
java

#1

I try Learn Java with Chrome, Firefox, Safari on Mac 10.10.5.
but same results with this screenshot.

Other Courses

  • Learn SQL Has same problem

Where do i type #1
#2

If you are behind a firewall that you have control of I can give you some addresses to whitelist.

If not, then you might be able to get through with the Tor browser: https://www.torproject.org/projects/torbrowser.html


#3

I think may have a firewall I can't control between internet and my laptop.
Check firewall on Mac, I set Chrome with allow all incoming connection.
So, I try with Tor browser, but same


And I try another course Learn Python I finished before, It's fine.
Is there any way to leave course and restart again ?


#4

Tor users are at the mercy of the exit node that they use (making encryption and certificate checking important) and I suppose you might have gotten one that was firewalled.. No idea how common that is, but I just tried a good 10 and they all worked for the Java track. You can get a new exit node in that menu you've got open there.

It could have been a temprorary issue on Codecademy's end, but it's working for the rest of us so if you're getting the same thing at another time then that seems like an unlikely explanation.

Next to that onion icon you've got noscript, but that looks to me like it's off, so that shouldn't be it either.

Do tell if you figure it out! :o


#5

@albionsrefuge @ionatan Thanks for helping!
I found problem is in my account....
Same laptop, network, browser with a new account I create by another google account
It's working


#6

That is very interesting! Inexplicable but interesting :slightly_smiling:


#7

This problem may solved in another way
but...I'm curious what about my origin account ?
Can it be solve ?


#8

I don't know about that yet, but I'm trying to find out!


#9

Could you give me the links to your two codecademy.com accounts please?


#10

@canyu -- could I get the links to your two profiles please?


#11

@albionsrefuge
Sorry , I'm busy those day @@
https://www.codecademy.com/Canyu
https://www.codecademy.com/methodBlaster74843


#12

No problem.

The link to that second account says that it was created in Jan 16, 2012 -- that doesn't seem to match up with just being created.

When you login to those accounts:

Are you using the Email field or the Google link?


#13

Oh, I forgot....that maybe I created before :stuck_out_tongue_winking_eye:
I am sure First one with Google account
Second one with email fineaisa@hotmail.com


#14

I want to make sure I have this straight:

https://www.codecademy.com/Canyu -- for this one you sign in with the Google link?


#15

Yes, That's right
Just like this vdieo