[reported #125, #128] 'rails generate controller Pages' isn't working correctly


#1

When on the create controller task I enter the command and it doesn't bring me back to the cmd line $. On top of that when I check for the file it wasn't created in the controllers folder. Have tried to reset several times. No success.


#2

I've had the same problem all morning. You can press Ctrl+Z to force out the command to get back to the command line $bash, but I've tried everything and can't get my controller to create.


#3

Hi Tyler and @jaredmccammon,

Sorry to hear your experiencing issues with the course! Would you mind posting screenshots of what you see after attempting to run the command (rails generate controller Pages)?

Thanks :slightly_smiling:


#4

I just tried it again today and it for whatever reason works now. Basically after entering the command it responded with a warning about spring then seemed to pause not returning anything past that, indefinitely. The $ prompt never reappeared and it was stuck. I'm sure what that means but it works now.


#5


#6

@betawhiz95312 ?
Is that timing out without doing anything or something?


#7

Just wanted to add my name to the list of people having this problem. I see this post is 19 days old. I can't get > rails generate controller Pages to work. I have the same result as the screenshot posted above. Not sure what to do except come back later and hope for better.

Lots of other problems on the first part of the Rails learning module too. Spent most of today dealing with issues rather than learning. But to the credit of CodeAcademy the people available on support were stellar and had a lot of patience and understanding, so a big thank you to all of them.


#8

@manas.nine I'm glad they were helpful :slight_smile:

Would you mind posting the browser and operating system you're using so I can update our bug report with the details?

Thanks! :slight_smile:


#9

@zystvan : Sure.

Chrome for Windows Version 49.0.2623.87 m
Windows 10 Pro


#10

@manas.nine Are you still getting the error?


#11

I'm having the same error. I've tried a number of times.


#12

@aleafonthewind Hm, that's no good :confused:

Could you screenshot the window so I can see what you're seeing, please?


#13

I had the same error. I just tried again and it is improved now. I was still getting the warning but the system did create the file. I can see it in the terminal using 'ls', but still nothing in the window. Please fix it asap, because I cannot edit the files in the terminal anyway.


#14

My error upon running 'rails generate controller Pages':


#15

I was able to make it work by restarting the exercise on the menu and refreshing the browser using Ctrl + F5. Using Google Chrome on Windows 10.


#16

I am having this same problem. It worked initially, but I had to restart the project due to a different error, and now the generate controller command is giving a warning, and not doing anything.


#17

I got the same error when I type rails generate controller Pages. It says"Warning: You're using Rubygems 2.0.14.1 with Spring. Upgrade to at least Rubygems 2.1.0 and run gem pristine --all for better startup performance ". What should I do?


#18

I got the same error with the same warning as @steveguang mentioned. When will this issue be resolved?


#19

I'm in the same boat as @bnr12. I got the Pages working at first, but then I had to restart the project and now I can't get my Pages!


#21

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.