Ravenous Part 4 - whatwg-fetch polyfill

Hi there! I got some questions concerning step 7 from Part 4 of the Ravenous proyect.

  1. What is a Polyfill?
  2. How does whatwq-fetch work?

also, when runing npm install whatwg-fetch --save this message appears to me:

"npm WARN ts-pnp@1.0.1 requires a peer of typescript@* but none is installed. You must install peer dependencies yourself.

  • whatwg-fetch@3.0.0
    updated 1 package and audited 36241 packages in 34.032s
    found 78 vulnerabilities (63 low, 15 high)
    run npm audit fix to fix them, or npm audit for details"

I installed Typescript, don’t know what peer dependencies are. I very much appreciate some orientation.

I believe it was Remy Sharp who first coined this term. Let me dig around and see what comes up in a search…

https://remysharp.com/2010/10/08/what-is-a-polyfill

First off,

https://whatwg.org/

1 Like

Thanks my friend! :slight_smile:

1 Like