Rake not working


#1

When I tried to rake the db.migrate, I got this:

$ rake db.migrate
rake aborted!
Gem::LoadError: You have already activated rake 12.3.1, but your Gemfi
le requires rake 10.4.2. Prepending bundle exec to your command may
solve this.
/var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:313:in
check_for_activated_spec!' /var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:31:in
block in setup’
/var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:26:in `
map’

I tried bundle exec rake db.migrate and got lots of errors also. I can’t continue with the lesson because the database is not set up and seeded. Please help.


#2

Hi @jonathanmeraz,

What errors do you get when you run bundle exec rake db:migrate? If they’re different, we might be able to fix them fairly easily. Otherwise, you could reset the exercise and see if starting over fixes the issue.


#3

I had a similar problem as well at the rake db:migrate step 3. I’ve tried resetting my entire Association I exercise by going page by page but have not gotten it to work. It keeps on jumping me back to step 5 and is still saving my progress even though the files have been “reset”. I wish there were a button to reset a specific exercise instead of resetting the whole course. Help.


#4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.